LiteLoader API for Minecraft 1.7.4,1.7.2 and 1.6.4

This is an API that runs mods.  If you don’t know what an API is, but need this for a mod, go down to the install guide now.  The rest of this will confuse you, since it’s all technical developer words and other things that scare me.

LiteLoader API

Now, for those of you who’re devs looking for a reason to use this, here are the things this API was made for.  It’s made for smaller mods, such as minimaps and chat tabs.  If your mod doesn’t use a single block/item ID, or change how any of the vanilla blocks work, this is for you.  It was originally designed for the Voxel team, who’s main focus is on minecraft’s look.  The GUI, mostly.  It also works for macro mods (mods that automate some tasks like walking or building without adding blocks to the game.)

In short, this is Forge without having all of the bells and whistles.  It doesn’t support any major game features, and never will according to the author.  It’s an API, which was made because forge is bigger than most of the mods this API supports.

How to use the LiteLoader API for Minecraft 1.7.4

  • If you’re not a developer, you install it
  • If you are a developer, you use this to make smaller mods (GUI changes) rather than forge

LiteLoader API for Minecraft 1.7.4 Pros and Cons

Pros:

  • A smaller API
  • Easier to code small, non-game-play mods with
  • It’s perfectly compatible with Forge and ModLoader

Cons:

  • None to think of.

LiteLoader API version 1.7.2 for Minecraft 1.7.4 Changelog

  • New 1.7 Version but its still BETA so might be unstable

How to Install the LiteLoader API for Minecraft 1.7.4

  1. Make sure minecraft, and the launcher are closed
  2. Download the latest version of the installer (See Note1)
  3. Run the installer you downloaded and find your minecraft folder if it isn’t automatically found
  4. Select any cascadingTweaks you have (like Minecraft Forge.  If you don’t select it it Forge will not load after installation)
  5. Click OK to make the profile which uses this loader
  6. A message will say liteloader has installed properly
  7. Select liteloader from the profiles in the launcher
  8. Run Minecraft and enjoy

Note1: Stop complaining about the forge and liteloader installers.  Go look on the official forum post for this API to see it’s the installer from the forum page. We always link to the download links the mod makers put up.

LiteLoader API for Minecraft 1.7.4,1.7.2 and 1.6.4

2014-02-18 11:03:57

Developed by Verblick | Sitemap

MinecraftDL is not affiliated with Mojang AB